読者です 読者をやめる 読者になる 読者になる

kikeda1104's blog

備忘録・技術に関することを書いています。(webエンジニア)

capybara-webkitのインストール

Ruby Gem Capybara

こんにちは。kikeda1104です。

nokogiriと利用して、スクレイピングをしようと思いましたが、jsによるrenderが発生しているサイトだったので、gem capybaraとcapybara-webkitのインストールをします。インストール最中につまづきがあったので、備忘録として書いています。

前提

capybaraのインストール

$ gem install capybara

capybara-webkitのインストール

$ gem install  capybara-webkit

f:id:kikeda1104:20141026161353p:plain

上記のエラーメッセージが出力されますので、Qtというアプリケーション・ユーザインタフェース (UI) フレームワークをインストールすることで、改善されます。

Qtのインストール

$ brew insatll qt

capybara-webkitの再インストール

$ gem install capybara-webkit

参考

MacにCapybara-webkitをインストール - 僕の車輪の再発明

Qt - Wikipedia

以上です。